[En cours de publication] problème d'envoi - instance IGN

Bonjour,
Nous envoyons des milliers d’images sur l’instance IGN depuis deux types de caméras :

  • une GoPro Max classique pour des vues 360°
  • une imajbox pour des images plus précises

Nous avons écrit des scripts Python pour l’envoi massif sur ces deux types de caméras :

  • rien de particulier pour celui de la GoPro (ajout d’un logo en nadir de chaque image et envoi via le geovisio_cli en version Windows) : ce script fonctionne très bien
  • un peu plus compliqué pour celui de l’imajbox (extraction ffmpeg d’images depuis des vidéo .avi, extraction de métadonnées depuis des csv en sortie de caméra, ajout d’exif unitairement dans chaque image puis envoi avec le geovisio_cli toujours dans sa version Windows) : c’est sur celui-là que nous avons beaucoup de séquences qui se retrouvent (aléatoirement ?) sous le statut ‘En cours de publication’.

Ces deux scripts ont été réadaptés de ceux écrits il y a quelques années pour l’envoi dans Mapillary.

Ce statut ‘En cours de publication’ m’interroge. Est-ce que l’instance IGN ne peut pas traiter toutes les images que nous envoyons ? Il arrive que des jours tout passe, d’autre beaucoup moins et ce de manière aléatoire.

Comment peut-on faire pour analyser ce problème ? Dois-je aussi envoyer les images dans l’instance OSM et comparer les statuts de publication sur chacune des instances ? Voir tout envoyer dans l’instance OSM ?

Si vous avez des idées, nous sommes preneurs.

Cordialement,
Fabien Goblet [Sogefi]

1 Like

Ca ressemble au problème déjà constaté avec d’autres extractions d’images depuis des vidéos. L’algo de floutage a des souci avec ces fichiers jpg qui ne sont pas tout à fait standards.

Une solution de contournement est d’extraire les images depuis les vidéos, en png, et de les convertir ensuite en jpg.

voir ici : Utilisation de la dashcam Tesla - #13 par cquest

1 Like

Oui, il y a des chances que ce soit ça. On a repéré des photos qui provoquent des erreurs au niveau de l’API de floutage et j’ai pas encore eu le temps de regarder ce qui coinçait. Fort possible que ce soit celles là !

L’extraction ffmpeg directement en JPEG n’était surtout pas de bonne qualité, pour ça que j’avais opté pour une extraction en PNG puis une compression JPEG avec imagimagick.

1 Like

Merci pour ces pistes. Je fais un correctif des scripts.

1 Like

C’était donc la bonne piste :slight_smile:
Les 80 Go de séquences envoyées depuis hier soir sont toutes en statut ‘Publié’.

Le script a été changé pour sortir des PNG depuis ffmpeg. Puis on convertit directement ces PNG en JPG via Pillow.

Merci à tous.

1 Like